Cisco ASDM will not launch with version 7.x

If you have the latest version of Java 7 and you’re using ASDM 7.x it will not work.  You must uninstall Java and downgrade to version 6!  Found here – http://www.oldapps.com/java.php