Mastering Kali Linux for Advanced Penetration Testing

If you are looking for a great guide on learning Kali linux look no further!
Download

While installing Exchange 2013 it reports there are Exchange 2003 servers in the network when there are not

One or more servers in the existing organization are running Exchange 2000
Server or Exchange Server 2003.

Installation can’t proceed until all
Exchange 2000 or Exchange 2003 servers are removed.

If you previously upgraded from Exchange 2003 to a version before 2013 then you may not have removed Exchange 2003 or 2000 server properly.  If this is the case you can run adsiedit.msc and find the following location.
Load Configuration
services>Microsoft exchange>first organization>administrative groups>  In here find your administrative group.  Then you will see a “servers” container.  Go in there and delete any name references to your old servers that are no longer in your network.

Migrating BES server to Blackberry Express

http://www.blackberry.com/btsc/KB20793
Transporter Tool  http://docs.blackberry.com/en/admin/deliverables/16660/BB_ET_overview_554166_11.jsp

Setting up dual internet connections without BGP on a cisco router

hostname Router
!
ip cef
!####First we are going to setup a monitor that will use icmp or ping to contact the gateway of ISP1. It will do this every 5 seconds####!
ip sla monitor 1
type echo protocol ipIcmpEcho 12.34.45.1
threshold 3
frequency 5
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
type echo protocol ipIcmpEcho 23.34.56.1
threshold 3
frequency 5
ip sla monitor schedule 2 life forever start-time now
!
!####Here we are going to setup monitoring objects and tell it to point to the above monitors####!
track 101 rtr 1 reachability
!
track 102 rtr 2 reachability
!
!####NAT must be configured on the interfaces in order to setup the rules####!
interface FastEthernet0
ip address 192.168.1.254 255.255.255.0
ip nat inside
!
interface s0/0
ip address 12.34.45.2 255.255.255.0
ip nat outside
!
interface s0/1
ip address 23.45.67.2 255.255.255.0
ip nat outside
!
ip classless
!####Configure your gateway and their tracking objects####!
ip route 0.0.0.0 0.0.0.0 12.34.45.1 track 101
ip route 0.0.0.0 0.0.0.0 23.45.67.1 track 102
!####Configure your outbound NAT statements####!
ip nat inside source route-map ISP1 interface s0/0 overload
ip nat inside source route-map ISP2 interface s0/1 overload
!####Change your MX records for your mail server to both of your ISP’s IP addresses then configure below####!
ip nat inside source static tcp 192.168.1.10 25 12.34.45.2 25 route-map ISP1 extendable
ip nat inside source static tcp 192.168.1.10 25 23.45.67.2 25 route-map ISP2 extendable
!
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
!####Configure route maps for reference in NAT statements####!
route-map ISP2 permit 10
match ip address 10
match interface s0/1
!
route-map ISP1 permit 10
match ip address 10
match interface s0/0
!

enable SSH on Cisco router

config t
ip domain-name MyDomain.com
crypto key generate rsa usage-keys modulus 1024
wr mem

Offline Files Issues

If for whatever reason you cannot get your offline files to synchronize and you want to make sure you have a backup of them before messing with any of your settings follow these steps.
Download CSCCMD.exe version 1.1
csccmd /extract /target:c:temp /recurse2
If your offline files point to an old network location and you need to change it you can do so with these steps.
csccmd.exe /moveshare:OldServer NewServer

Exchange 2007 migration links

http://www.msexchange.org/articles_tutorials/exchange-server-2007/migration-deployment/practical-look-migrating-exchange-2003-exchange-2007-part3.html
http://www.simple-talk.com/exchange/exchange-articles/upgrading-to-exchange-server-2007/

Using powershell to move offline address book to another server

Move-OfflineAddressBook -Identity <OfflineAddressBookIdParameter> -Server <ServerIdParameter>
Example move offline address booked named “my oab” to server named n2server-01
Move-OfflineAddressBook -Identity “My OAB” -Server N2Server-01

Add internet mail flow to hub transport server using powershell

New-SendConnector -Name “Internet” -Usage Internet -AddressSpaces “*” -SourceTransportServers “N2Hub-01” -DNSRoutingEnabled:$true -UseExternalDNSServersEnabled:$true
And this to allow anonymous connections
Set-ReceiveConnector -Name “Default Server Name” -Server N2Hub-01 -PermissionGroups AnonymousUsers,ExchangeUsers,ExchangeServers,ExchangeLegacyServers

Integrate Blackberry Enterprise Server(BES) with Exchange

  1. Login to server using an account that will run teh BES services.
  2. Run setup.exe
  3. Click continue installation
  4. On the licensing agreement enter your user name and organization information click next
  5. Select the “I would like the installation process to create a BlackBerry Configuration Database” radio button and click next.
  6. Select “BlackBerry Enterprise Server” radio button.  Select all the options below it and click next.
  7. Select the “I accept the terms in the license agreement” radio button and click next.
  8. Select the “I accept the terms in the license agreement” radio button and click next.
  9. On the database page if you have an existing SQL server you can select SQL database on another computer.  If not the installer will install SQL express 2005.
  10. On the next page enter the windows account information for your BES services.  In the name field type the name of the BES that you want the administration service to display.
  11. Verify the settings on the summary page and click Install.
  12. Click yes to reboot the computer when you’re ready.
  13. Make sure you when the PC restats you login with the same username/password that you originally used to login to start the installation.
  14. One the next screen enter the relevant database information for your SQL server.
  15. It will prompt you to create a new database select yes.
  16. click ok when it says database created successfully.
  17. Click next to accept defaults on the next page.
  18. On the CAL and SRP information page do the following
  19. Type in the key, type in teh hostname, type in the port number, click verify.
  20. Type in the SRP identifier, type in the SRP authentication key, click verify.
  21. On the next page type in the Microsoft Exchange server name, type in the mailbox account that has appropriate permissions.  Click check name, apply and ok.
  22. In the application extensibility settings page do the following
  23. In the pool name type the fqdn to create a blackberry mds integration service pool
  24. In the blackberry mds application repository name type the name of the blackberry mds integration service database verify the default values for the port numbers.  Enter the credentials for the administrator and the publisher.
  25. click yes to create a new database.  Click ok when it is successful.
  26. Type the database name for monitoring.
  27. Select your instant messenger settings.
  28. On the administration settings page.  In the pool name type the fqdn that the setup application can use to create the blackberry administration service web address.
  29. In the new password and confirm password type the password for the ssl certificate that the blackberry administration service uses for authentication with browsers.
  30. On the LDAP settings type the ldap settings to integrate with your active directory environment.
  31. In the advanced administration settings type a password to access blackberry administration services.
  32. Click start services
  33. Save all of the web addresses for future management purposes.
  34. click close, you’re done.